Degraded app performance
Incident Report for Privacy
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 20:28 UTC
Investigating
We are currently investigating an issue that's causing slow loading times on the Privacy web, mobile, and extensions app. Authorizations are not impacted.
Posted Apr 25, 2024 - 18:54 UTC
This incident affected: Privacy.com Dashboard and Privacy App.