Incorrect transaction dates on dashboard
Incident Report for Privacy
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 24, 2024 - 04:50 UTC
Investigating
We are currently investigating an issue where transaction dates are appearing incorrectly on our web and mobile dashboards. Authorizations are not impacted.
Posted Feb 23, 2024 - 23:21 UTC
This incident affects: Privacy.com Dashboard and Privacy App.