Privacy.com website down
Incident Report for Privacy
Resolved
This incident has been resolved.
Posted Jul 18, 2024 - 17:42 UTC
Investigating
We're investigating an issue impacting Privacy.com, which is unable to load. Transaction processing and the Privacy app is not impacted.
Posted Jul 18, 2024 - 16:30 UTC