Privacy App load times

Incident Report for Privacy

Resolved

This incident has been resolved.
Posted May 31, 2023 - 20:30 UTC

Update

We are continuing to investigate this issue.
Posted May 31, 2023 - 20:06 UTC

Investigating

We're currently investigating an issue causing degraded service on our Privacy App. At this time, expect slow load times. Authorizations are not impacted. We will provide an update as soon as possible.
Posted May 31, 2023 - 19:01 UTC
This incident affected: Privacy.com Dashboard.