Some authorization declines
Incident Report for Privacy
Resolved
This incident has been resolved.
Posted Jun 06, 2023 - 15:56 UTC
Investigating
We are investigating an issue that may cause some authorizations to decline unexpectedly.
Posted Jun 06, 2023 - 14:26 UTC
This incident affected: Transaction Processing.