Degraded performance.

Incident Report for Privacy

Resolved

This incident has been resolved.
Posted May 14, 2024 - 17:50 UTC

Investigating

We are currently investigating an issue that's causing slow loading times on the Privacy web, mobile, and extension apps. Authorizations are not impacted.
Posted May 14, 2024 - 17:41 UTC
This incident affected: Privacy.com Dashboard and Privacy App.